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1 Description of the problem 

An example of a cylindrical water container with a conical base is selected to illustrate some 

features of ELPLA for analyzing circular cylindrical shell elements. 

2 Container geometry and properties 

A cylindrical water container with a conical base of a radius of a = 3.0 [m] and a height  

of H = 12.0 [m] is considered as shown in Figure 10.1. Thickness of the container wall is 0.3 [m], 

while that for the conical base is 0.2 [m]. Figure 10.1 shows the container with dimensions  

and supports, while the container material and unit weight of the water are listed in Table 10.1.  

Table 10.1 Container material and water unit weight  

Modulus of Elasticity of the container material  Ec = 10000    [kN/m2] 

Poisson's ratio of the container material    νc = 0.17        [-] 

Unit weight of the water     γw  = 10        [kN/m3] 

 

 
Figure 10.1 Cylindrical water container with dimensions and supports 
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3 Numerical Analysis 

In the analysis, the height of the tank is divided into two main segments, the first one is divided 

into 30 subsegments (30×0.3 [m]), while the second is divided into 20 subsegments (20×0.15 [m]) 

as shown in Figure 10.2.  
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Figure 10.2 Finite element mesh of the container with boundary condition 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing a cylindrical water container 

with a conical base. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and steps  

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 10.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 10.3). 

 

 
Figure 10.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 10.3, define the analysis type of the problem.  

As the analysis type is a cylindrical water container with a conical base problem,  

select "Analysis of rotational Shell" button, and check "Shell with an opening base" option, 

then click "Next" button to go to the next Form. After clicking "Next" button, the "Options" Form 

appears, Figure 10.4. 
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The last Form in the wizard is the "Options" Form, Figure 10.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 10.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 10.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Water container". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 10.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Water container] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely entered. 

To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 10.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a cylindrical water container" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 10.6 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, a cylindrical water container with a conical base of a radius of a = 3.0 [m]  

and a height of H = 12.0 [m] is considered, the height of the tank is divided into two main segments, 

the first one is divided into 30 subsegments (30×0.3 [m]), while the second is divided  

into 20 subsegments (20×0.15 [m]). To define the FE-Net for this tank, choose "FE-Net Data" command 

from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 10.7.  

This wizard will guide you through the steps required to generate a FE-Net, the first Form of the wizard 

is the "Shell type" Form, which contains a group of templates of different shapes of nets. These net 

templates are used to generate standard nets. 
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Figure 10.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 
 

- In the "Shell type" options choose "Irregular shell" button 
- Type 0.01 in the "Tank base radius Rb" edit box, which is approximately zero 

(Note that: from the principles of axis-symmetrical shell elements, radius cannot be exactly 
zero) 

 
To identify the first main segment  

 
• Type 3 in the "Height Hw" edit box 
• Type 3 in the "Upper radius Ro" edit box 
• Type 20 in the "Number of segments Ns" edit box 
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To identify the second main segment  
 

• Type 9 in the "Height Hw" edit box 
• Type 3 in the "Upper radius Ro" edit box 
• Type 30 in the "Number of segments Ns" edit box 

- Click "Next" button to go to the next Form 
 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 10.8, The user can edit the data of each 

segment individually or all of them by using "In Table" button, If it is necessary. 

 

 
Figure 10.8 "Irregular shell" Form 

Click "Finish" in "Analysis of rotational shell" wizard, the generated FE-Net appears Figure 10.9. 

 

 

 

 

 



Example 10  

 

 

   -10.11- 

 
Figure 10.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 10.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 10.9 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 10.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight  

of the tank, and the filled material properties. 

 

 
Figure 10.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 10.11 

appears. In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the wall and  

the base of the tank as they differ in thickness. Then click "OK" button. 
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Figure 10.11 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the tank base  

 

- Choose "Select Elements" command from "Graphically" menu in the window of Figure 10.10 

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at the 

corner of the region. Then, drag the mouse until a rectangle encompasses the required group of 

elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the tank base as Figure 10.12 

- Choose "Elements Groups" command from "Graphically" menu in the window of Figure 10.10, 

"Group Regions" dialog box Figure 10.13 appears 

- Define the "Group No." of the base elements as type "2", while "Group No." of the wall 

elements will be as type "1", where type "1" is the default "Group No.", then click "OK" button 
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Figure 10.12 Selecting the elements that include the tank base 

 
Figure 10.13 "Group Regions" dialog box 
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To enter the unit weight of the container, choose "Unit weight" command from "Shell Properties" 

menu in Figure 10.10. The following dialog box in Figure 10.14 with a default unit weight  

of 25 [kN/m3] appears, type 0 in the "Unit weight" edit box to neglect the self-weight of the tank, 

then click "OK" button. 

 

 
Figure 10.14 "Unit weight" dialog box 
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To define the filled material properties of the container, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 10.10. The following form in Figure 10.15 appears. 

 

 
Figure 10.15 "Filled material type/Element size" Form 

To define the filled material properties of the container: 

 

- Select "Liquid container" option 

- Type 12 in the "Height of the liquid" edit box 

- Type 10 in the "Unit weight of the liquid" edit box 

 

To define the element size of the container: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at the nodes of segments 

- Click "OK" button 
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Figure 10.16 "Shell Properties" window after defining the container properties 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 10.16 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 10.16 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 10.17 appears. 

 

 
Figure 10.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 10.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the support as shown in Figure 10.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 10.17). The "Supports/ Boundary Conditions" dialog box 

in Figure 10.19 appears. 
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Figure 10.18 Selection of the node that has the support 
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In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define the vertical support 

- Click "OK" button 

 

 
Figure 10.19 "Supports/ Boundary Conditions" dialog box 
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Figure 10.20 "Supports/ Boundary Conditions" window after defining the support 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 10.20 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 10.20 to close the "Supports/ 

Boundary conditions" window and return to the main window 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 10.21 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 10.21. In this example, there is not applied load, as the vertical 
load has been already defined by the unit weight of the tank, while the hydrostatic pressure on the 
tank wall is defined by the unit weight of water. 
 

 
Figure 10.21 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 10.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 10.21 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 10.22. 

 

 
Figure 10.22 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix)  

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 10.23 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 10.23 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 10.24. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 10.24 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 10.25). 

 

 
Figure 10.25 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command, 

the following option box in Figure 10.26 appears 

- In the "Distribution of Internal Forces" option box, select "Radial forces Nr" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 10.27. 
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Figure 10.26 "Distribution of Internal Forces" option box 

 

 
Figure 10.27 Radial forces on the shell wall 
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To view the meridional moments on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command. 

The following option box in Figure 10.28 appears 

- In the "Distribution of Internal Forces" option box, select "Meridional moments My" as an 

example for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 10.29. 

 

 
Figure 10.28 "Distribution of Internal Forces" option box 

 
Figure 10.29 Meridional moments on the shell wall 
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To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 10.30 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 10.30 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 10.31 appears 

- In this check group box, check both "Supports Reactions RV" and "Supports /Boundary 

Conditions" check box  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 10.31 "View Grouping" check group box 
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Figure 10.32 Element groups of the tank 

 

 

 

 

 

 

 

 

 

 

 


